Japanese voices can already be manually enabled

Bittah_CommanderBittah_Commander
First Assault Rep: 1,755
Posts: 172
Member
edited April 23 in General Chat
People have been asking for Japanese voices for a while already and it turns out that it's been possible to just manually enable them yourself all along. To do this, go to the game's directory and from there go to \Data\audio\Fmod_Build.
In that directory you'll see the files sac_bank06_voice_eng.fsb and sac_bank06_voice_jpn.fsb among a number of other .fsb files.

To enable the Japanese voices, you simply need to replace the .fsb file ending with "eng" with the one that ends with "jpn".
In other words: rename or delete sac_bank06_voice_eng.fsb, then copy sac_bank06_voice_jpn.fsb and rename that copy to sac_bank06_voice_eng.fsb.

I've played for several hours weeks after doing this and it works perfectly so far.

Note1: It's no problem if you do this while the game is running and you're sitting in the menu (you also don't need to restart the game afterwards).
Note2: if it doesn't work after replacing sac_bank06_voice_en.fsb, try deleting both sac_bank06_voice_el.fsb and sac_bank06_voice_jl.fsb, then copy sac_bank06_voice_jpn.fsb and rename it to sac_bank06_voice_el.fsb (sac_bank06_voice_jl.fsb should still be missing).
VeldrinPrismriverAlmalexionTylerCSlipperySnailTarkinSokuzani

Comments

  • PrismriverPrismriver
    First Assault Rep: 1,310
    Posts: 95
    Member+
    edited April 8
    f17fd5a4fc7471bce5622e57d0cc358f_6381879-comment-meme-give-that-man-a-cookie_468-558.jpeg
  • Bittah_CommanderBittah_Commander
    First Assault Rep: 1,755
    Posts: 172
    Member
    edited April 18
    I edited my first post to add Note1 and Note2. Apparently it didn't work for everyone and some people have to mess with sac_bank06_voice_el.fsb and sac_bank06_voice_jl.fsb instead. Replacing both of those with the Japanese version at the same time will apparently result in distorted sounds however, so that's why you need to delete one of them if you replace the other.
  • ho1yho1y
    First Assault Rep: 750
    Posts: 29
    Member
    edited April 21
    id just want to be able to lower the volume of the announcer saying "YOU ARE THE LAST ONE STANDING, KEEP CALM YOU CAN DO IT" cause usually when this guy is sayign that I cant hear where the hell the enemy is...
  • ho1yho1y
    First Assault Rep: 750
    Posts: 29
    Member
    edited April 29
    does this change the announcer's voice?
  • Bittah_CommanderBittah_Commander
    First Assault Rep: 1,755
    Posts: 172
    Member
    edited May 1
    Yes, it changes the all voices (including Aramaki's/the announcer's) with the exception of Kuro's.
    Have a look at the video I just uploaded to hear what it's like (with exception of the music, of course):
  • 89j923j89fj89289j923j89fj892
    First Assault Rep: 715
    Posts: 33
    Member
    edited May 2
    the results are mixed

    using Z, X and C in the shooting range to test it, some are in English, some in Japanese, it's a real mess

    id rather wait for an official choice rather than this.. feels like ive modded an elder scrolls game
  • Bittah_CommanderBittah_Commander
    First Assault Rep: 1,755
    Posts: 172
    Member
    edited May 3
    @89j923j89fj892
    I'm not sure what you're talking about. Whenever I play, unless there's a Kuro player present, I don't hear a single English sentence spoken by anyone, ever (as you can hear in the video I linked to above). Which character were you testing this with?

    To make sure the game isn't able to get the English voices from anywhere, try deleting sac_bank06_voice_en.fsb, sac_bank06_voice_el.fsb and sac_bank06_voice_jl.fsb (you shouldn't hear any voices whatsoever after doing this) and then rename sac_bank06_voice_jpn.fsb to one of those 3 (try changing it to the 3 file names one by one until you can hear voices again).
    As mentioned before, you can rename the file while you're sitting in the lobby (without restarting the game) to make the testing process quicker.
  • 89j923j89fj89289j923j89fj892
    First Assault Rep: 715
    Posts: 33
    Member
    edited May 16
    @89j923j89fj892
    I'm not sure what you're talking about. Whenever I play, unless there's a Kuro player present, I don't hear a single English sentence spoken by anyone, ever (as you can hear in the video I linked to above). Which character were you testing this with?

    To make sure the game isn't able to get the English voices from anywhere, try deleting sac_bank06_voice_en.fsb, sac_bank06_voice_el.fsb and sac_bank06_voice_jl.fsb (you shouldn't hear any voices whatsoever after doing this) and then rename sac_bank06_voice_jpn.fsb to one of those 3 (try changing it to the 3 file names one by one until you can hear voices again).
    As mentioned before, you can rename the file while you're sitting in the lobby (without restarting the game) to make the testing process quicker.

    how about make it simple by editing files, deleting non-required ones and upload the archive somewhere?
  • Bittah_CommanderBittah_Commander
    First Assault Rep: 1,755
    Posts: 172
    Member
    edited May 17
    The only file you need is sac_bank06_voice_jpn.fsb and since everybody already has it, it's pointless to upload it. It also wouldn't work that way because what it needs to be renamed to depends on your region or system language. And while just having 3 copies of sac_bank06_voice_jpn.fsb with the jpn part changed to en, el and jl, it turns out that causes all vocals to be distorted.

    So the easiest way is really just to follow the 2-4 steps below:
    1. Delete the 3 files (sac_bank06_voice_en.fsb, sac_bank06_voice_el.fsb and sac_bank06_voice_jl.fsb).
    2. Rename sac_bank06_voice_jpn.fsb by changing the jpn part to en and then check if you hear voices ingame.
    3. If there are no voices, replace en (that used to be jpn) with el and test again.
    4. If there still are no voices ingame, change el to jl and test again.
    89j923j89fj892
  • IitLssIitLss
    First Assault Rep: 300
    Posts: 4
    Member
    edited May 26
    Hmmm I was messing with my ingame settings while using the steam launcher and I switched the game to 32-bit and it changed all sound to japanese after it asked to restart the game O.o I have not touched my folder thingy at all which is weird.